Цикл с постусловием (цикл "ДО")

План:

  • Общий вид, назначение и способы применения оператора repeat;
  • Экспериментальный раздел работы;
  • Решение задач по данной теме

Оператор repeat, как и while, используется при написании программ, в которых число повторов (циклов) заранее не известно и может быть определено только во время работы программ.
Оператор repeat отличается от while тем, что:

  • условие проверяется после выполнения операторов тела цикла и таким образом тело цикла всегда будет выполнено хотя бы один раз;
  • оператор repeat прекращает выполняться, как только значение выражения условия равно True (истина)

Блок - схема, соответствующая оператору repeat:

Формат записи:

repeat
<оператор 1>;
    ………………
    <оператор n>
until <условие окончания цикла>;

Операторы, заключенные между repeat и until, являются телом цикла.
Для того чтобы цикл завершился, необходимо, чтобы в теле цикла находился оператор (операторы), влияющий на значение условия.
Экспериментальный раздел работы

Как известно, число называется простым, если оно делится только на единицу и на себя. Проверить, является ли число n простым, можно делением n на 2, на 3 … и проверкой полученного после каждого деления остатка. Если остаток равен 0, то найдено число, на которое n делится без остатка. Сравнив n с полученным числом, можно определить, является ли n простым. Ниже приведен текст программы, которая проверяет, является ли введенное с клавиатуры число простым.

program prost;
var
    n, d, r : integer;
begin
    write ('Введите целое число:');
    readln (n);
    d: = 2;
    repeat
        r: = n mod d;
        if r <> 0
            then d: = d + 1;
    until r = 0;
if d = n
    then writeln ('n, ' - простое число')
    else writeln (n, ' - не является простым числом');
end.

  1. Изобразить блок-схему к решению предыдущей задачи задачи.
  2. С помощью оператора repeat измените программу prost так, чтобы она требовала у вас пароль, например 111, и если пароль верный, перед запросом числа выводила сообщение "Молодец!". Если же на третьей попытке был введен неверный пароль, организуйте выход из программы.
  3. Напишите программу вычисления суммы положительных чисел, вводимых с клавиатуры, которая завершает работу, как только вводится неположительное число.

 

 

 

#s3gt_translate_tooltip_mini { display: none !important; }

Категория: