Задачи линейной структуры

Вариант 1
1. Составьте программу вычисления периметра и площади треугольника по введенным в диалоге трем сторонам.
var
a,b,c,p,s:real;
begin
readln(a,b,c);
p:=a+b+c;
writeln('Периметр треугольника равен ', p:8:2);
s:=sqrt(p/2*(p/2-a)*(p/2-b)*(p/2-c));
writeln('Площадь треугольника равна ', s:8:2)
end.

2. Составьте программу, вычисляющую значение среднего арифметического трех натуральных чисел.
var
a,b,c:word;

s:real;
begin
readln(a,b,c);
s:=(a+b+c)/3;
writeln('Среднее арифметическое трех чисел равно ', s:8:2);
end.

3. Составьте программу, вычисляющую по введенному значению радиуса длину окружности и площадь круга.

var

r,l,s:real;

begin

readln® ;

l:=2*pi*r;

s:=Pi*sqr®;

writeln('Длина кгруга = ', l:8:2,'   Площадь круга = ', s:8:2);

end.

4. Составьте программу, вычисляющую периметр квадрата по указанному значению его площади.

var

a,s,p:real;

begin

readln(s);

a:=sqrt(s);

p:=4*a;

writeln('Периметр квадрата равен ',p:8:2);

end.

5. Составьте программу, вычисляющую скорость прямолинейного
равномерного движения тела по указанным значениям перемещения и времени,
в течение которого это перемещение совершено.

var

t,s,v:real;

begin

readln(s,t);

v:=s/t;

writeln('Скорость перемещения равна ',v:8:2);

end.

Вариант 2
1. Составьте программу вычисления периметра и площади прямоугольного треугольника по длинам двух его катетов.
2. Составьте программу, вычисляющую значение среднего геометрического двух натуральных чисел.
3. Составьте программу, вычисляющую произведение цифр заданного четырехзначного числа n.

var

n,p:longint;

begin

readln(n);

p:= (n div 1000) * ( n div 100 mod 10) * (n mod 100 mod 10) * ( n mod 10);

writeln('Произведение цифр четырехзначного числа ', p);

end.

4. Составьте программу, вычисляющую площадь квадрата по указанному значению его периметра.

5. Составьте программу, вычисляющую расстояние между двумя пешеходами,
идущими навстречу друг другу, которые начали путь одновременно.

Вариант 3
1. Составьте программу вычисления гипотенузы и площади прямоугольного треугольника, если известны его катеты.

 

var

a,b,c,s:real;

begin

readln(a,b);

c:=sqrt(sqr(a)+sqr(b));

s:=1/2 *a*b;

writeln('Гипотенуза равна ',с:8:2 'Площадь равна',s:8:2 );

end

2. Составьте программу для вычисления квадратного корня из суммы модулей трех вещественных чисел.

3. Составьте программу, вычисляющую сумму членов бесконечно убывающей
геометрической прогрессии, если известен ее первый член и знаменатель
прогрессии, а также количество ее членов.
4. Составьте программу, вычисляющую площадь кольца, образованного двумя окружностями, если известны радиусы этих окружностей.
5. Составьте программу, вычисляющую длину стороны правильного шестиугольника по указанному значению его площади.

Вариант 4
1. Составьте программу вычисления периметра и площади равностороннего треугольника по введенной длине его стороны.

2. Составьте программу, вычисляющую время встречи двух автомобилей,
если известно расстояние между двумя пунктами, откуда они вышли
навстречу друг другу одновременно, а также их скорости.
3.
Составьте программу, вычисляющую площадь правильного пятиугольника, если
известна его сторона и радиус вписанной в него окружности.
4. Составьте программу, вычисляющую 5%, 20% и 60% от значения выражения: A*C+B-C*B. если известны значения A, B, C.

5. Составьте программу, вычисляющую сумму арифметической прогрессии,
если известен ее начальный член и разность прогрессии, а также
количество ее членов.

Категория: